Getting started with ReadXplorer

This guide is intended for beginners using ReadXplorer for the first time. It will give a short
introduction about the main features of the software and how they can be used. Please be aware
that this guide is not intended to replace the complete manual.
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1. What is ReadXplorer?

ReadXplorer is a viewer and automatic analysis platform for Next-Generation Sequencing data. It can
be used to display a reference genome sequence with genomic features (annotations) alongside with
different tracks that represent read data that was mapped against the reference. In contrast to most
other viewers, ReadXplorer also offers a wide range of analysis functions that can be applied to the
visualized data.

2. When to use ReadXplorer?
The Software can be used with every data-set created by mapping read data against a reference
sequence. This can be for example a resequencing experiment or an RNA sequencing run.

3. What input data is needed?
The software has to be provided with both a reference sequence and the corresponding read
mapping data.

The reference sequence can be provided in Genbank, EMBL or Fasta format. If the Fasta format is
used corresponding genomic features (annotations) can be added in GTF/GFF2 or GFF3 format. It is
advisable to import genomic features because most analysis functions only work properly when they
are present. Nevertheless, ReadXplorer will also accept reference sequences without any annotation.

The mapped reads must be provided in sam/bam format. These files must have been created by
mapping the read data against the exact same reference as the one imported into ReadXplorer. This
is extremely important: during import the mapping files will be assigned to a reference. If the
reference noted down in the sam/bam file does not match the reference sequence it is assigned to
no reads will be visible! You are free to use the mapping tool you prefer (e.g. Bowtie, bwa, Tophat) as
long as the output is in standard conform sam/bam format!. Mapping data imported is called a track
within the software. ReadXplorer is primarily designed for Illumina short-read data (single- or paired-
end) but is not limited to it. As long as the read data can be mapped against a reference and the
output is in sam/bam format ReadXplorer can handle the data. Of course not all analysis functions
offered by ReadXplorer are sensible to use with every kind of input data. However, the software is
not designed to patronize its user unless it is inevitable and hence all analysis functions can be used
with any read mapping data-set.

L https://samtools.github.io/hts-specs/SAMv1.pdf



4. Which installer should I choose?

The ReadXplorer homepage provides various installers suitable for different setup scenarios:
Zip-x86/64-AllSystems

This is actually no installer but simply a zip file containing the ReadXplorer software which can easily
be used on all operating systems. It can be unzipped and ReadXplorer can be started by executing
one of the binaries in the “bin” directory. There are different binaries for Windows and Linux in this
directory. You must install an appropriate version of Java on your own before you can start the
program.

Exe-Windows-i386-incl Java

This is a standalone installer for Windows x86. It requires at least Windows 7. The installer comes
with its own Java version and hence no Java needs to be pre-installed on your system. Java will only
be installed for ReadXplorer. This means that if you already have a Java installation it will not be
altered. This installer comes with the 32bit version of Java. It will run on 32bit Windows systems but
you can only use a limited amount of RAM (heap-size):

The maximum theoretical heap limit for the 32-bit JVM 1is 4G. Due to various
additional constraints such as available swap, kernel address space usage, memory
fragmentation, and VM overhead, in practice the limit can be much lower. On most
modern 32-bit Windows systems the maximum heap size will range from 1.4G to 1.6G.
On 32-bit Solaris kernels the address space 1is limited to 2G. On 64-bit operating
systems running the 32-bit VM, the max heap size can be higher, approaching 4G on
many Solaris systems.?

Exe-Windows-x64-incl Java

This is a standalone installer for Windows x64. It requires at least Windows 7. The installer comes
with its own Java version and hence no Java needs to be pre-installed on your system. Java will only
be installed for ReadXplorer. This means that if you already have a Java installation it will not be
altered. This installer comes with the 64bit version of Java and hence it can only be installed on a
64bit Windows. This is the recommended way of installing ReadXplorer on a Windows computer.

Linux-i386-incl Java

This is a standalone installer for Linux. It should work on all major Linux distribution although there
are so many different distributions available that we cannot guarantee that. We test the Linux
installers on Fedora 23. The installer comes with its own Java version and hence no Java needs to be
pre-installed on your system. Java will only be installed for ReadXplorer. This means that if you
already have a Java installation it will not be altered. This installer comes with the 32bit version of
Java. It will run on 32bit Linux systems but you can only use a limited amount of RAM (heap-size):

The maximum theoretical heap 1limit for the 32-bit JVM 1is 4G. Due to various
additional constraints such as available swap, kernel address space usage, memory
fragmentation, and VM overhead, in practice the limit can be much lower. On most
modern 32-bit Windows systems the maximum heap size will range from 1.4G to 1.6G.
On 32-bit Solaris kernels the address space is limited to 2G. On 64-bit operating

2 http://www.oracle.com/technetwork/java/hotspotfaq-138619.html#gc_heap_32bit



systems running the 32-bit VM, the max heap size can be higher, approaching 4G on

many Solaris systems.2

The installer is compressed. Once downloaded open a terminal and navigate to the download folder.
Decompress the installer:

» gunzip readxplorer 2.2-1inux-1i386.sh.gz
Afterwards you can launch the extracted sh file:

» sh ./readxplorer 2.2-1inux-1386.sh
Linux-x64-incl Java

This is a standalone installer for Linux. It should work on all major Linux distribution although there
are so many different distributions available that we cannot guarantee that. We test the Linux
installers on Fedora 23. The installer comes with its own Java version and hence no Java needs to be
pre-installed on your system. Java will only be installed for ReadXplorer. This means that if you
already have a Java installation it will not be altered. This installer comes with the 64bit version of
Java and will only run on 64bit Linux systems. This is the recommended way of installing
ReadXplorer on a Linux computer.

The installer is compressed. Once downloaded open a terminal and navigate to the download folder.
Decompress the installer:

» gunzip readxplorer 2.2-linux-x64.sh.gz
Afterwards you can launch the extracted sh file:

» sh ./readxplorer 2.2-linux-x64.sh

DMG-Mac-incl Java

This is a disk image file for OS X. Like most Mac programs it does not have a real installer. The DMG is
simply opened and then the application is installed by “drag and dropping” it to the “Application”
folder. Java is included in the ReadXplorer application and hence no Java needs to be pre-installed,
an existing Java Version will not be altered. Additionally, GNU R (needed for the differential
expression analysis) is included in this installer. A GNU R instance is automatically launched when you
start ReadXplorer and automatically stopped when you close ReadXplorer. We utilize RServe listening
on port 6311 to make GNU R accessible from within Java. Please make sure that no other RServe
instance is running when you launch ReadXplorer as this might interfere with the bundled GNU R. If
you never heard of RServe, don’t worry, you will most probably be safe to launch ReadXplorer
without taking care of anything. This is the recommended way of installing ReadXplorer on OS X
computer.



5. The first run
We recommend that you start with the test data-set provided on our homepage?. This data-set
contains simulated RNA-Seq data from E.coli. Once downloaded you have to unzip it first.

When you start ReadXplorer for the first time it will look like this:
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ReadXplorer - ion and Analysis of Mapped Seq es: Quick Start

1. Open/Create a database (File -> Open/Create Database”)

2. Import a reference genome ("File -> Import data”)

3. Import a track ("File -> Import data”)

4. Explore your reference genome and tracks (via Dashboard, toolbar buttons or “Visualisation™ menu)
5. Run an analysis on your data (via toolbar buttons or *Tools™ menu)

For HELP goto Help -> Help Contents or check out the manual.

3 ftp://ftp.cebitec.uni-bielefeld.de/pub/readxplorer_repo/E.coli-simulated-Testdata.zip



Select “Open existing database”, navigate to the folder where you unzipped the test-data set and
open the database file (called “database” in this case). The view will now show you the different
references and associated tracks in the database:

ﬂi.- ReadXplorer 2.2.0 - C:\Users\Kai\Desktop\E.coli-simulated-Testdata\E.coli-simulated- Testdata'\database - O *
File Visualisation Tools Help
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Close this and open another database

Nodes Description Import Date Mark for action

= E.coli_NC_010473. L.obk E.coli_NC_010473.1.gbk 08.05.2016 O
= Track #1 simulated_normal 1.bam 06.05.2016 O
W Track #2 simulated_normal2.bam 08.05.2015 O
e Track #3 simulated_normal3.bam 06.05.2016 O
= Track #4 simulated_normal4.bam 06.05.2016 O
W Track #5 simulated_knockDown 1.bam 06.05.2016 O
- Track #6 simulated_knockDown2,.bam 06,05, 2016 O
= Track #7 simulated_knockDown3.bam 06.05.2016 O
W Track =8 simulated_knockDown4.bam 06.05.2015 O
- Track #9 simulated_upRegulated 1.bam 06,05,2016 O
W Track #10 simulated_upRegulated2.bam 08.05.2016 O
W Track #11 simulated_upRegulated3.bam 06.05.2016 O
- Track #12 simulated_upRegulated4.bam 08.05.2015 O

Export statistics of all tracks from the DB: Select all nodes
Store track statistics TR R IR A0 Deselect all nodes

A database can hold multiple references and each reference can have multiple tracks associated to it.
In this case, the database contains one reference and twelve associated tracks. Four tracks belong
together; they are simulated replicates of different conditions one might find during an RNA-Seq
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experiment. All tracks with “normal” in their name represent RNA-Seq data generated under
standard conditions (e.g. E. coli grown on normal media, at room temperature). In contrast the tracks
with “knockDown” or “upRegulated" in their name contain data one might find when generating
RNA-Seq data from non-standard conditions (e.g. different media used, heat stress etc.). In these
tracks some genes are down or up regulated in comparison to the normal data-set. You can mark the
tracks and open them using the “open selected items in new tab” button. We will mark and open one

track of each condition.



The following tab will open:
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This is ReadXplorer’s main viewing window. The different elements are described in the manual.
Aside from the visualization ReadXplorer offers various analysis tools. As a first example we will use
the “Feature Coverage Analysis” to look for uncovered coding sequences (CDS) in the data-set. All
analysis functions are configured by a wizard. You can access all analysis functions from the “Tools”
menu.



The first wizard panel asks which tracks should be included in the analysis. We select all
“knockDown” tracks and additionally check the “Combine selected tracks” checkbox. When this box
is checked, ReadXplorer will combine the read information from the selected tracks and treat them
as if they were contained in one single track.
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Parameters W gimulated_normal 1.bam

3. Read Classification Selection

4, Feature Type Selection

5. Press Finish’' to start %+ simulated_normal3.bam

Modes

W cimulated_normal2.bam

e~ cimulated_normal4.bam

W simulated_knodkDown 1. bam
e cimulated_knodkDown 2. bam
W simulated_knockDown3.bam
W gimulated_knodkDown<4.bam
e simulated_upRegulated 1.bam
W gimulated_upRegulated2.bam
e simulated_upRegulated3.bam

DOOESEEEEEEE ]

W gimulated_upRegulated4.bam

Combine selected tracks | Selectall ] l Deselect all




In the next panel the parameters for the analysis are set. As we want only uncovered CDS we check

“Detect uncovered instead of covered features”, additionally we decrease the “Min percent covered”
value to “50”.

r© -
ﬂi.' Feature Coverage Analysis Parameter Wizard Iﬁ
Steps Feature Coverage Analysis Parameters
1. Track Selection
2. Feature Coverage The first parameter defines how many percent of a
Analysis Parameters feature have to be covered with at least a coverage
3. Read Classification Selection larger or equal to the second parameter value to be
4, Feature Type Selection detected as "covered feature”,
5. Press 'Finish' to start The checkbox deddes whether only the mappings on
the strand of a feature are counted, or all mappings
within the range of the feature. I
E Min percent covered
10 Min coverage counting for the percentage

Detect uncovered instead of covered features
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In the next panel we can select which read classes should go into the analysis. Please refer to the
manual for a detailed explanation about the different read classes. We also select “Combine both
strands”. This option is useful for data-sets that are not strand specific, as in such data-sets the reads
can map to the forward or reverse strand arbitrarily regardless of their biological origin.

v |
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Steps Read Classification Selection

1. Track Selection

2. Feature Coverage Analysis 1, Select the mapping dasses to indude in the analysis (See Help -> Classification for details).
Parameters Further decide if only uniquely mapped reads should be induded, or all mapped reads.

3. Read Classification Mote that "Perfect”, "Best” and "Common” mapped reads are never unigue, thus cannot be selected
Selection together with "unigue”,

4, Feature Type Selection
5.  Press 'Finish' to start

Single Perfect Mappings [ only uniguely mapped reads
[7] Perfect Mappings 0 Minimum mapping quality
Single Best Match Mappings

[7] Best Match Mappings

|| Common Match Mappings

2. Select if mappings from the feature strand, from the opposite strand or combined from both
strands are used in the analysis.

Mapping strand selection:
() Feature strand (Default)

() Oppaosite strand
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In the next step the annotation type the analysis should be applied to must be selected. As we intend

to look at CDS we only select the “CDS” feature type. We the finished button is clicked the analysis
will start.
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While the analysis is running you can continue using ReadXplorer normally. The status of the analysis
is indicated by a progress bar in the lower right corner. You can also start additional analysis tasks
and ReadXplorer will process them in parallel.
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Once the analysis is finished a new window showing the results will open.
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If you select an entry from the results table the viewer component will automatically jump to the
start position of the associated annotation.
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As the data-set is not strand specific you can adjust the view to show all reads on the fw strand.
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This is just one simple example of an integrated analysis function. For the next example we will use
the more complex “Differential Gene Expression Analysis”, which relies on external tools that are not
a native part of ReadXplorer. They need the statistical programming language GNU R to run and you
need to set up the connection between ReadXplorer and GNU R once before you can start using the
analysis. The setup options for different operating systems are described in the manual in detail. In
general you have to visit the GNU R options panel within ReadXplorer at least once. The panel is
located under “Tools” > “Options”. On Windows we highly recommend that you just select
“Download and Install Gnu R”. This will automatically install everything that is needed to run the
“Differential Gene Expression Analysis” on a windows machine. If you already have GNU R installed:
Don’t worry, your existing installation will not be altered. For Linux operating systems and OS X you
will have to install GNU R and the needed packages on your own as described in the manual. When
you have done that go back to the GNU R options panel and set up the connection parameters that
match your installation. If you are using a local R installation most of the time it should be sufficient
to just change the radio button to “Manual”. Once the setup is complete you can start the
“Differential Gene Expression Analysis” located in the tools menu.



Once again a configuration wizard will collect the necessary information before the analysis is
started. In the first panel you have to select the tool you want to use. For this tutorial we select
“DESeq2”. Please refer to the manual for a short introduction of all the tools offered. Additionally, it
is advisable to also read the publication of the tool you want to use.
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Steps Choose analysis software (1. from 7)
1. Choose analysis software
.. Please choose the analysis tool you want to use for the differential gene expression analysis.
DEseqd fv




On the next panel select the tracks that should be included in the analysis. This time we select all

“normal” and all “knockDown” tracks because we want to compare these to conditions.
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Steps Select tracks (2. from 6)

1. Choose analysis software

2. Select tracks Please select a reference sequence:
3. Select conditions

4, General Setup

5. Read Classification Selection

6. Start the analysis

Flease select the tracks you want to use for the analysis:

simulated_normal 1.bam
simulated_normal 2.bam
simulated_normal3.bam
simulated_normal4.bam

simulated_knockDown 1.bam
simulated_knockDown2.bam
simulated_knockDown3.bam
simulated_knockDown4.bam
simulated_upRegulated1.bam
simulated_upRegulated2.bam
simulated_upRegulated3.bam
simulated_upRegulated4.bam

< Back ][Next> ]| Finish |[ Cancel ]| Help




You must assign each selected track to a condition. Obviously, it only makes sense to assign all

I"

“norma

tracks to one condition and all “knockDown” tracks to the other.

ﬂi.- Differential Gene Expression Analysis

It |

Steps Select conditions (3. from 6)

1. Choose analysis software

2. Select tracks

3. Select conditions

4, General Setup

5. Read Classification Selection
6. Start the analysis

Tracks:

Condition one:

simulated_normal 1.bam
simulated_normal2.bam
simulated_normal3.bam
simulated_normal4.bam

Condition two:

simulated_knodDown 1.bam
simulated_knodDown2.bam
simulated_knodkDown3.bam
simulated_knodDown<4.bam

< Badk ” Next >

Finish Cancel

Help




In the next panel the annotations that should be used for the analysis run must be selected. This time
we choose “Gene”.

ﬂu Differential Gene Expression Analysis

Steps General Setup (4. from 6)

1. Choose analysis software
2. Select tracks Annotation types that should be used for the analysis:
3. Select conditions
4. General Setup
5
5]

Read Classification Selection
Start the analysis Exon

Start offset: Stop offset:

o] o]

[ save used parameters and results in an R data file for later processing

|C: \Wsers\Kai\DiffExpResult.rdata
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In the “Read classification” panel we change the radio button to “Combine both strands”.

ﬂu Differential Gene Expression Analysis

|'\

Steps Read Classification Selection (5. from &)
1. Choose analysis software
2. Select tracks 1. Select the mapping dasses to indude in the analysis (See Help -> Classification for details).
3. Select conditions Further decide if only uniquely mapped reads should be induded, or all mapped reads.
4. General Setup MNote that "Perfect”, "Best™ and "Commaon” mapped reads are never unique, thus cannot be selected
5. Read Classification together with "unigue”,
Selection

Start the analysis

Single Perfect Mappings [ only uniquely mapped reads
|:| Perfect Mappings 1] Minimum mapping quality
Single Best Match Mappings

[] Best Match Mappings

[] Commen Match Mappings

2. Select if mappings from the feature strand, from the opposite